CISCO AUX BACK-TO-BACK 实例
Click on the routers in the topology below to view their configurations.
router 2500 AUX----NULL MODEN CABLE-----ROUTER 2500 AUX
Before You Begin
This configuration has Cisco 2500-series routers back-to-back using the async AUX port. The Cisco AUX port is connected to another Cisco AUX port running PPP. The connection has been configured to allow IP for a permanent connection.
Ingredients
For this recipe, you need the following:
A null modem cable.
You may also need an RJ45-to-DB25 adapter converter. For more information on cables, see the Cables documentation.
Router 1
version 11.1
service udp-small-servers
service tcp-small-servers
!
hostname Router1
!
interface Ethernet0
no ip address
shutdown
!
interface Serial0
no ip address
shutdown
!
interface Serial1
no ip address
shutdown
!
interface Async1
ip address 192.168.10.1 255.255.255.0
! -- the IP address on the AUX ports of both routers must be in the same subnet
encapsulation ppp
! -- set PPP as encapsulation
async dynamic routing
async mode dedicated
!
no ip classless
ip route 0.0.0.0 0.0.0.0 Async1
logging buffered
!
line con 0
exec-timeout 0 0
line aux 0
modem InOut
transport input all
rxspeed 38400
txspeed 38400
flowcontrol hardware
line vty 0 4
login
!
end
Router 2
version 11.1
service udp-small-servers
service tcp-small-servers
!
hostname Router2
!
!
interface Ethernet0
no ip address
shutdown
!
interface Serial0
no ip address
shutdown
!
interface Serial1
no ip address
shutdown
!
interface Async1
ip address 192.168.10.2 255.255.255.0
! -- the IP address on the AUX ports of both routers must be in the same subnet
encapsulation ppp
async dynamic routing
async mode dedicated
!
no ip classless
ip route 0.0.0.0 0.0.0.0 Async1
logging buffered
!
line con 0
exec-timeout 0 0
line aux 0
modem InOut
transport input all
rxspeed 38400
txspeed 38400
flowcontrol hardware
line vty 0 4
login
!
end
Debug and Show Commands to Use for Troubleshooting
Check under line aux 0:
Issue the show line aux 0 command.
Verify that all signals are up. For example, CTS, RTS, DTR, CD. If nothing appears next to them, they are up. If "No" appears next to them (for example, No-CTS), it means they are down.
Router1#show line aux 0
Tty Typ Tx/Rx A Modem Roty AccO AccI Uses Noise Overruns
A 1 AUX 38400/38400 - inout - - - 0 0 0/0
Line 1, Location: "", Type: ""
Length: 24 lines, Width: 80 columns
Baud rate (TX/RX) is 38400/38400, no parity, 2 stopbits, 8 databits
Status: Ready, Active, Async Interface Active
Capabilities: Hardware Flowcontrol In, Hardware Flowcontrol Out
Modem Callout, Modem RI is CD, Line is permanent async interface
Modem state: Ready
Special Chars: Escape Hold Stop Start Disconnect Activation
^^x none - - none
Timeouts: Idle EXEC Idle Session Modem Answer Session Dispatch
00:10:00 never none not set
Modem type is unknown.
Session limit is not set.
Time since activation: 00:00:30
Editing is enabled.
History is enabled, history size is 10.
Full user help is disabled
Allowed transports are pad v120 telnet. Preferred is telnet.
No output characters are padded
No special data dispatching characters
Line is running PPP for address 192.168.10.2.
0 output packets queued, 1 input packets.
Async Escape map is 00000000000000000101000000000000
Modem hardware state: CTS* DSR* DTR RTS
Use the show line command to determine the async interface of the AUX ports. Though most routers have the AUX port as interface async 1, Access servers have the AUX port interface after the tty lines. For example, if your router has 16 async/modem lines, then the AUX port is line 17. In this case, the AUX port must be configured on interface async 17. Configure the AUX port based on the show line outputs. The example below verifies that the AUX port is on int async 1.
Router1#show line
Tty Typ Tx/Rx A Modem Roty AccO AccI Uses Noise Overruns
* 0 CTY - - - - - 0 0 0/0
A 1 AUX 38400/38400 - inout - - - 0 0 0/0
2 VTY - - - - - 0 0 0/0
3 VTY - - - - - 0 0 0/0
4 VTY - - - - - 0 0 0/0
5 VTY - - - - - 0 0 0/0
6 VTY - - - - - 0 0 0/0
Use these debug commands to verify that the link comes up correctly:
debug ppp negotiation - To display information on PPP traffic and exchanges while negotiating Link Control Protocol (LCP), Authentication, and Network Control Protocol (NCP). A successful PPP negotiation will first open the LCP state, then Authenticate, and finally negotiate NCP. If CONFREQs are being sent out, but no CONFACKs being received, check that the cabling is correct and whether the correct line (interface async x) is configured.
debug ppp authentication - To display PPP authentication protocol messages, including Challenge Handshake Authentication Protocol (CHAP) packet exchanges and Password Authentication Protocol (PAP) exchanges.
debug ppp error - To display protocol errors and error statistics associated with PPP connection negotiation and operation.
Before attempting any of the above debug commands, please see Important Information on Debug Commands
文章录入:csh 责任编辑:csh