交换机命令之一--华为

1.在基于IOS的交换机上设置主机名/系统名:
  switch(config)# hostname hostname
  在基于CLI的交换机上设置主机名/系统名:
  switch(enable) set system name name-string
  2.在基于IOS的交换机上设置登录口令:
  switch(config)# enable password level 1 password
  
  在基于CLI的交换机上设置登录口令:
  switch(enable) set password
  switch(enable) set enalbepass

  3.在基于IOS的交换机上设置远程访问:
  switch(config)# interface vlan 1
  switch(config-if)# ip address ip-address netmask
  switch(config-if)# ip default-gateway ip-address
  在基于CLI的交换机上设置远程访问:
  switch(enable) set interface sc0 ip-address netmask broadcast-address
  switch(enable) set interface sc0 vlan
  switch(enable) set ip route default gateway

  4.在基于IOS的交换机上启用和浏览CDP信息:
  switch(config-if)# cdp enable
  switch(config-if)# no cdp enable
  为了查看Cisco邻接设备的CDP通告信息:
  switch# show cdp interface [type modle/port]
  switch# show cdp neighbors [type module/port] [detail]
  在基于CLI的交换机上启用和浏览CDP信息:
  switch(enable) set cdp {enable|disable} module/port
  为了查看Cisco邻接设备的CDP通告信息:
  switch(enable) show cdp neighbors[module/port] [vlan|duplex|capabilities|detail]

  5.基于IOS的交换机的端口描述:
  switch(config-if)# description description-string
  基于CLI的交换机的端口描述:
  switch(enable)set port name module/number description-string

  6.在基于IOS的交换机上设置端口速度:
  switch(config-if)# speed{10|100|auto}
  在基于CLI的交换机上设置端口速度:
  switch(enable) set port speed moudle/number {10|100|auto}
  switch(enable) set port speed moudle/number {4|16|auto}

  7.在基于IOS的交换机上设置以太网的链路模式:
  switch(config-if)# duplex {auto|full|half}
  在基于CLI的交换机上设置以太网的链路模式:
  switch(enable) set port duplex module/number {full|half}

  8.在基于IOS的交换机上配置静态VLAN:
  switch# vlan database
  switch(vlan)# vlan vlan-num name vla

  switch(vlan)# exit
  switch# configure teriminal
  switch(config)# interface interface module/number
  switch(config-if)# switchport mode access
  switch(config-if)# switchport access vlan vlan-num
  switch(config-if)# end
  在基于CLI的交换机上配置静态VLAN:
  switch(enable) set vlan vlan-num [name name]
  switch(enable) set vlan vlan-num mod-num/port-list

  9. 在基于IOS的交换机上配置VLAN中继线:
  switch(config)# interface interface mod/port
  switch(config-if)# switchport mode trunk
  switch(config-if)# switchport trunk encapsulation {isl|dotlq}
  switch(config-if)# switchport trunk allowed vlan remove vlan-list
  switch(config-if)# switchport trunk allowed vlan add vlan-list
  在基于CLI的交换机上配置VLAN中继线:
  switch(enable) set trunk module/port [on|off|desirable|auto|nonegotiate]
  Vlan-range [isl|dotlq|dotl0|lane|negotiate]

  10.在基于IOS的交换机上配置VTP管理域:
  switch# vlan database
  switch(vlan)# vtp domain domain-name
  在基于CLI的交换机上配置VTP管理域:
  switch(enable) set vtp [domain domain-name]

11.在基于IOS的交换机上配置VTP 模式:
  switch# vlan database
  switch(vlan)# vtp domain domain-name
  switch(vlan)# vtp {sever|cilent|transparent}
  switch(vlan)# vtp password password
  在基于CLI的交换机上配置VTP 模式:
  switch(enable) set vtp [domain domain-name] [mode{ sever|cilent|transparent }][password password]
  12. 在基于IOS的交换机上配置VTP版本:
  switch# vlan database
  switch(vlan)# vtp v2-mode
  在基于CLI的交换机上配置VTP版本:
  switch(enable) set vtp v2 enable

  13. 在基于IOS的交换机上启动VTP剪裁:
  switch# vlan database
  switch(vlan)# vtp pruning
  在基于CL I 的交换机上启动VTP剪裁:
  switch(enable) set vtp pruning enable

  14.在基于IOS的交换机上配置以太信道:
  switch(config-if)# port group group-number [distribution {source|destination}]
  在基于CLI的交换机上配置以太信道:
  switch(enable) set port channel moudle/port-range mode{on|off|desirable|auto}

  15.在基于IOS的交换机上调整根路径成本:
  switch(config-if)# spanning-tree [vlan vlan-list] cost cost
  在基于CLI的交换机上调整根路径成本:

  switch(enable) set spantree portcost moudle/port cost
  switch(enable) set spantree portvlancost moudle/port [cost cost][vlan-list]

  16.在基于IOS的交换机上调整端口ID:
  switch(config-if)# spanning-tree[vlan vlan-list]port-priority port-priority
  在基于CLI的交换机上调整端口ID:
  switch(enable) set spantree portpri {mldule/port}priority
  
  switch(enable) set spantree portvlanpri {module/port}priority [vlans]

  17. 在基于IOS的交换机上修改STP时钟:
  switch(config)# spanning-tree [vlan vlan-list] hello-time seconds
  switch(config)# spanning-tree [vlan vlan-list] forward-time seconds
  ` switch(config)# spanning-tree [vlan vlan-list] max-age seconds
  在基于CLI的交换机上修改STP时钟:
  switch(enable) set spantree hello interval[vlan]
  switch(enable) set spantree fwddelay delay [vlan]
  switch(enable) set spantree maxage agingtiame[vlan]

  18. 在基于IOS的交换机端口上启用或禁用Port Fast 特征:
  switch(config-if)#spanning-tree portfast
  在基于CLI的交换机端口上启用或禁用Port Fast 特征:
  switch(enable) set spantree portfast {module/port}{enable|disable}

  19. 在基于IOS的交换机端口上启用或禁用UplinkFast 特征:
  switch(config)# spanning-tree uplinkfast [max-update-rate pkts-per-second]
  在基于CLI的交换机端口上启用或禁用UplinkFast 特征:
  switch(enable) set spantree uplinkfast {enable|disable}[rate update-rate] [all-protocols off|on] 文章录入:csh    责任编辑:csh

(0)

相关推荐

  • 交换机命令之三--华为

    41. 配置默认路由: switch(enable) set ip route default gateway 42. 为一个路由处理器分配VLANID,可在接口模式下使用下列命令: router(config)# interface interface number router(config-if)# mls rp vlan-id vlan-id-num < BR> 43. 在路由处理器启用MLSP: router(config)# mls rp ip 44. 为了把一个外置的路由处理器接

  • 交换机命令之二--华为

    20. 为了将交换机配置成一个集群的命令交换机,首先要给管理接口分配一个IP地址,然后使用下列命令:       switch(config)# cluster enable cluster-name 21. 为了从一条中继链路上删除VLAN,可使用下列命令: switch(enable) clear trunk module/p ort vlan-range 22. 用show vtp domain 显示管理域的VTP参数. 23. 用show vtp statistics显示管理域的VTP参

  • 交换机命令之一--华为

    1.在基于IOS的交换机上设置主机名/系统名: switch(config)# hostname hostname 在基于CLI的交换机上设置主机名/系统名: switch(enable) set system name name-string 2.在基于IOS的交换机上设置登录口令: switch(config)# enable password level 1 password 在基于CLI的交换机上设置登录口令: switch(enable) set password switch(ena

  • 交换机命令之四--华为

    61. 要显示HSRP路由器的状态: router# show standby type-number group brief 62. 用命令show ip igmp确定当选的查询器. 63. 启动IP组播路由选择: router(config)# ip muticast-routing 64. 启动接口上的PIM: dal llasr1>(config-if)# ip pim {dense-mode|sparse-mode|sparse-dense-mode} 65. 启动稀疏-稠密模式下的P

  • Golang通过SSH执行交换机操作实现

    简单实现通过输入指令,两步执行交换机命令. 输入执行换机的账号和密码.可以一次输入多个账号和密码,为了方便操作,规定了输入格式.如 用户名:主机IP;密码|用户名:主机IP;密码.举例admin;192.168.56.10;h3csw1|admin;192.168.56.11;h3csw2 输入要执行的命令,以;分割.例如system-view;dis cu; ​ 存在问题: 不够灵活.输入方式限制太死,输入特别字符也可能存在错误. 过于简陋. 功能简单. ​ 不过我的目的已经达到,我主要是了解

  • 详解Centos8 配置静态IP的实现

    安装centos 8之后,重启启动网络时,会出现以下报错 报错信息如下: Failed to start network.service: Unit network.service not found. 意思为无法重启网络服务,原因是无法找到network.service网络服务. 在rhel8(含centos8)上,在/etc/sysconfig/network-scripts/里也看不到任何脚本文件,没有传统的network.service.因此只能通过其它方法进行网络配置,包括NM命令工具

  • 华为各种型号交换机端口镜像配置方法总结

    有不少朋友在问华为交换机镜像方面的问题.通过本人现有的资料和文档,现把各种型号的交换机镜像方法总结一下.以便各位朋友能够方便查阅!在学配置之前,对于端口镜像的基本概念还是要一定的了解! 一.端口镜像概念: Port Mirror(端口镜像)是用于进行网络性能监测.可以这样理解:在端口A 和端口B 之间建立镜像关系,这样,通过端口A 传输的数据将同时复制到端口B ,以便于在端口B 上连接的分析仪或者分析软件进行性能分析或故障判断. 二.端口镜像配置 『环境配置参数』 1. PC1接在交换机E0/1

  • Cisco路由器交换机配置命令详解

    1. 交换机支持的命令: 交换机基本状态: switch: :ROM状态, 路由器是rommon> hostname> :用户模式 hostname# :特权模式 hostname(config)# :全局配置模式 hostname(config-if)# :接口状态交换机口令设置: switch>enable :进入特权模式 switch#config terminal :进入全局配置模式 switch(config)#hostname :设置交换机的主机名 switch(config

  • 华为3026交换机流量监控配置单

    注明:此交换机为华为3026系列交换机,做流量监控的必须配置要求 <Quidway>display current-configuration  [显示交换机配置信息]# sy sname Quidway#radius scheme system server-type huawei primary authentication 127.0.0.1 1645 primary accounting 127.0.0.1 1646 user-name-format without-domaindom

  • 华为公司三层以太网交换机基本原理及转发流程

    1. 二层转发流程1.1. MAC地址介绍MAC 地址是48 bit 二进制的地址,如:00-e0-fc-00-00-06.可以分为单播地址.多播地址和广播地址.单播地址:第一字节最低位为0,如:00-e0-fc-00-00-06多播地址:第一字节最低位为1,如:01-e0-fc-00-00-06广播地址:48 位全1,如:ff-ff-ff-ff-ff-ff注意:1)普通设备网卡或者路由器设备路由接口的MAC 地址一定是单播的MAC 地址才能保证其与其它设备的互通.2) MAC 地址是一个以太网

随机推荐